Waste Connections Security Alert

Browser Security

In April 2015 The PCI Security Standards Council established a new baseline declaring new cryptographic standards and migration guidelines. These standards are requirements set to protect credit card holder data and help prevent compromise of customer’s personal and financial data. Even though they have pushed out the date of implementations, it is important that you are using a browser that support the latest know secure protocols. Unfortunately many outdated browsers do not support these new standards.

It appears that you are using an outdated browser that does not support the recommended safe security practices. Our automated test is fairly reliable but does have issues identifying some browser capabilities. Therefore this diagnosis may be incorrect.

Please make sure you are using the latest version of your browser:
Get IE
Get Firefox
Get Chrome
Get Safari

Updating your browser will help keep your finaincial and personal information secure. In addition it will provide additional defense against hackers and identity thieves, while improving your experience at most web sites.

Thank you